How to install OCI8 on Ubuntu 14.04 and PHP 5.6

If your PHP application is using Oracle DBMS, you will need to install OCI8 PECL extension. Sometimes it’s quite tricky to make it work. Let’s make our hand dirty.

Requirements

Make sure met the following requirements:

  • Free account on Oracle website to download Oracle Instant Client and SDK files,
  • Full sudo access to your server,
  • PHP 5.6 and web server installed (tested with nginx and PHP-FPM).